Google SERPs API outage
Incident Report for SerpsBot API
Resolved
The infrastructure upgrade is complete and the services are stable now. We have been monitoring the services for the last several hours and we didn't notice any issues. Our customers should now experience very improved response times and great stability.
Posted Mar 17, 2022 - 07:16 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 17, 2022 - 00:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2022 - 00:56 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 17, 2022 - 00:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 17, 2022 - 00:17 UTC
Identified
Due to an unexpected surge in API requests, we are experiencing very high load. Please expect this degraded performance for the next couple of hours until we complete our infrastructure upgrade.
Posted Mar 17, 2022 - 00:17 UTC
Investigating
We are currently investigating this issue.
Posted Mar 16, 2022 - 23:38 UTC
This incident affected: API Services (Google Search API).